Redirector in all regions unreliable
Incident Report for Linkfire
Resolved
On February 28th 2017, 18:59 CET our engineers became aware of an issue affecting our redirector, landing pages as well as core API and Linkfire suite functionality. It quickly became evident that we, like many others, were affected by a major outage by our cloud hosting service provider Amazon Web Services (AWS) in the US-East-1 region.

As an unfortunate consequence, a number of links were affected and not working for a period of up to 3 hours.
At 20:22 CET our team of engineers established a temporary solution that fully restored functionality to 90% of Linkfire traffic, relying on Linkfire´s cache rather than Amazon Web Service storage.

Amazons S3 services has been reported as reestablished and at 22:54 CET the Linkfire redirector, landing page and all other functionalities were all back to normal.

At this time, we are not aware of what caused this event with AWS. While this was an exceptional occurrence beyond our control, we are obviously deeply sorry for the inconvenience it caused our users, artists and their fans.
Posted over 2 years ago. Feb 28, 2017 - 23:30 CET
Update
All Linkfire links are now restored back to normal operations and are fully functional worldwide.
The ability to create and edit links through our web app or API is also showing signs of working as normal. We await final confirmation from Amazon that all AWS S3 services are restored.
Next update will come in 30 minutes or when there is news.
Posted over 2 years ago. Feb 28, 2017 - 23:06 CET
Update
Amazon have restored service to the functions that underlie Linkfire links. We are now migrating back to AWS infrastructure and expect all Linkfire links to be fully operational worldwide in the next 15 minutes.
However, users still cannot create or edit links through our web app or API.
Next update will come in 30 minutes or when there is news.
Posted over 2 years ago. Feb 28, 2017 - 22:36 CET
Monitoring
Amazon report that they are making progress in fixing the S3 storage situation. Linkfire continues to serve links through contingency procedures.
While maintaining service Linkfire engineers continue to monitor the S3 storage situation and are ready to return to normal operations once AWS infrastructure is restored.
Next update will come in 30 minutes or when there is news.
Posted over 2 years ago. Feb 28, 2017 - 22:06 CET
Update
Amazon report that they believe they understand the root cause of the ongoing issue, and that they are working to repair it.
Linkfire has implemented contingency procedures, and we continue to monitor the situation.
Next update will come in 30 minutes or when there is news.
Posted over 2 years ago. Feb 28, 2017 - 21:41 CET
Update
While a majority of Linkfire links have had functionality restored, users cannot create or edit links through our web app or API. We apologize for the interruption to your workflow.
We continue to monitor AWS storage and are ready to return to normal operations once AWS infrastructure is restored.
Next update will come in 30 minutes or when there is news.
Posted over 2 years ago. Feb 28, 2017 - 21:11 CET
Update
A solution has been rolled out to Linkfire links in Europe which relies on Linkfire’s cache instead of AWS storage. You may experience issues on links that have not received any traffic during the last seven days.
We are working to implement this solution worldwide.
Posted over 2 years ago. Feb 28, 2017 - 20:22 CET
Update
Linkfire links are affected by Amazon Web Services downtime. Our engineers are currently implementing a workaround which will rely on our own cache, which will bring stability back to Linkfire links.
Posted over 2 years ago. Feb 28, 2017 - 20:02 CET
Identified
Amazon in the US have general operational issues, this is affecting Linkfire links. We are investigating possible workarounds.
Posted over 2 years ago. Feb 28, 2017 - 19:11 CET
Investigating
Our landing pages/redirectors are exhibiting downtime, Linkfire is investigating.
Posted over 2 years ago. Feb 28, 2017 - 18:59 CET