Interruption in Podcasts Analytics data

Incident Report for Linkfire

Monitoring

A fix has been implemented and we're monitoring the results.
Posted Jul 17, 2025 - 10:54 CEST

Identified

We are currently experiencing a service interruption affecting attribution data from Apple Podcasts. This means that any Apple Podcasts metrics since July 10th will not be available under Podcasts Analytics.

Our team is actively investigating the root cause and working closely with relevant partners to restore full attribution functionality. We understand the importance of this data and are treating this with high priority.
Posted Jul 16, 2025 - 12:15 CEST
This incident affects: ⚙️ APIs (📊 Insights).